Home > Windows 7 > Sp1 Error 0x800f0a12

Sp1 Error 0x800f0a12

Contents

Setting my Windows partition to be marked as active is what solved the problem in my case. Reply Danielle says: February 23, 2011 at 4:33 pm Yes, that is it. I am disappointed in the response. All that means is that to utilize Bitlocker on your system you would need to free space to create a System Reserved partition. navigate to this website

Reply joscon [Microsoft] says: October 28, 2016 at 5:31 pm Here's the only MS related link I could find for it: technet.microsoft.com/…/gg441289.aspx Reply joscon [Microsoft] says: October 28, 2016 at 5:31 Reply Danielle says: February 23, 2011 at 2:39 pm For SP1 to install on multi boot machines, windows' system partition has to be active. By viewing our content, you are accepting the use of cookies. Raid configuration is to stripe (I'm looking for speed).

Windows 7 Sp1 Error 0x800f0a12 Dual Boot

Would you like to answer one of these unanswered questions instead? I have two disks with multiple operating systems installed, so I boot from an IDE disk with my bootmanager installed, then run Windows 7 from a SATA disk off a single On computer: OS-RESEARCH DISKPART> automount Automatic mounting of new volumes enabled. Second, i don't have the System Reserved partition, though W7 had all the space it needed, why?

Press ‘Enter’. ->Restart you system and give one more attempt to install SP1. Reply nz says: February 25, 2011 at 10:28 am OK, finally I was able to install the service pack. Run cmd.exe as administrator. 2. Windows 7 Service Pack 1 Offline Installer This is necessary only when the BootMgr files are located on a partition other than the one containing the Windows directory and when the BootMgr files need to be serviced." technet.microsoft.com/…/dd744382(v=ws.10).aspx

I was able to get it working by disabling the IDE disk in the BIOS, I now notice that simply changing the boot disk order in the BIOS also appears to Service Pack Installation Failed With Error Code 0x800f0a12. Reply Anonymous says: October 28, 2016 at 5:31 pm I had error 800F0A12 when I found this blog and suggestions here brought me to my current 80073701 error. Please proceed at your own risk. Reply Stromi says: May 16, 2013 at 8:51 pm Joscon you're the best !

I encountered this error on several computers I attempted to update. Windows 7 Service Pack 1 Download Reply exasperated says: April 4, 2011 at 2:49 pm from DISKPART: Partition ### Type Size Offset partition 1 OEM 1536MB The CBS.log file sure doesn't spell it out plainly as to what is missing, only that there's a problem with "prnbr005.inf". Can you get the output of your current drive layout posted here so I can take a look at it?

Service Pack Installation Failed With Error Code 0x800f0a12.

If not, how do I enable automount? (I ran diskpart, but what do I have to then) Other people noticed that it might have something to do with Linux being installed In my case, at the BIOS screen I hit F12 (Gigabyte motherboard) to select boot drive (faster than changing boot order). Windows 7 Sp1 Error 0x800f0a12 Dual Boot Comparing the problem one to all the others, it seems that there are three missing locations of files. Mountvol /e That took much effort to fix and it was excruciatingly annoying to fix -- so I wish not to do it again 🙁 I have tried: - enabling automount in diskpart+reboot

So now I was out of ideas. Your suggestions brought me to my current 80073701 error. Reply joscon [Microsoft] says: October 28, 2016 at 5:31 pm We're talking about different things here. In this case it is possible to install the Win 7 SP1 by creating a link on the active boot partition linking to the system partition using the Windows mklink command. 0x800f0a12 Windows 2008 R2 Sp1

Thanks! Reply ↓ Alex on August 8, 2012 at 5:18 pm said: EliasAlucard , how You fix the grub problem ? Go through following step-by-step instructions: ->Click ‘Start’ and type: ‘command prompt’ in the search box. ->When results appear, put right-click on ‘Command Prompt’. Reply exasperated says: April 4, 2011 at 1:29 pm Hi, I have the same problem on an LG-X130 Atom-based netbook; which uses SplashTop (branded LG SmartON) as a "fast" boot option,

Did I participate in the recent DDoS attacks on Dyn's DNS service? Kb976932 I have a Fat 16 Dell Utility, NTFS Recovery and the NTFS OS C: which is marked as active. I installed W2K08 R2 on a partition I created using Acronis.

Also possible is that my assigning of drive letters with a third party tool caused the problem.

Reply joscon [Microsoft] says: October 28, 2016 at 5:31 pm It's always interesting to me to see people that think this is solely a Microsoft problem. Example use in the case that the system drive was not assigned a drive letter, and that drives unique name was determined by running the command ‘mountvol': windows6.1-KB976932-X86.exe /sysdrivedir:\?Volume{someGUID} Knowledge of thanks for the rapid response! Diskpart Even though the disk management from windows 7 professional can see the disk 1 even if its disable in bios, of course since its not accesing it through bios.

My setup is: Disk 0, (160gb maxtor), Partition 1 ntfs where wind is installed spanning entire disk, marked active, crash dump, system, pagefile etc. (note: none of that partition for sys You can insure the partition is being mounted by running a command prompt elevated as Administrator and entering “mountvol /E” at the command prompt. Or is there any way that I can (without re-installing Windows) rebuild the backup from the original source media? Created 3 partitions, all NTFS, installed W7 in the first one, later on changed paths of user data to second partition, again good practice and easier on backup strategies….should be an

admin to install the SP). All the above solutions ensure the windows partition is active, but to me this seams to be the easiest way to do it (KISS principle). When it determines that the active partition is not able to start Windows directly, it produces the error message. Reply exasperated says: April 4, 2011 at 3:48 pm i see.

Toying with the BIOS order is not something I'm that keen on doing, I did this back in vista for pretty much the same reason as now -- set windows drive Type: ‘command prompt’ in the search box. ->When results appear, put right-click on ‘Command Prompt’. I'm at the point of giving up right now. Reply joscon [Microsoft] says: October 28, 2016 at 5:31 pm @Nick; Glad you got it taken care of.

See All See All ZDNet Connect with us © 2016 CBS Interactive. However I get: C:\Users\ga>mountvol /E Access is denied. It is no help as it does not have my error message re bcedit. Essentially, the MBR resided on the XP volume, so using the diskpart or mountvol commands did not help resolve the 800f0a12 error.

So to boot to the sixth item in the list, the line would read GRUB_DEFAULT=5. As NapO commented above (25 Feb 2011 4:21 AM), I only had to assign a drive to that partition, install SP1, reboot and remove the drive letter. Go to ‘Run as Administrator’. Since it's a Dell with factory installed OS, I didn't have the W7 DVD to do a upgrade reinstall suggested by MS Support, so I borrowed one.

Using onboard Asus raid manager / with latest Asus/Intel driver etc. I've even tried mounting the FAT partition thinking that might have it confused but no luck. Running OpenSuse as well. Then I rebooted and voila — SP1 installed without a hitch.

Unmount after installation and you’re done without ruining your VM environment. Gparted, find the boot sda# and change the flag to the ntfs one, then reverse once completed. I tried “mountvol /E” but it didn't work. I have Fedora 14 installed on the same HD in free space, using/installed the Fedora bootloader.